
T2 Data Connection 

About the T2 Data Connection 
The T2 Data Connection is a feature unique to Corporate Taxprep that helps 
you minimize duplicate data entry, ensure consistency and assist you in 
optimizing tax positions when preparing returns for related and associated 
corporations. 

There are several functions that form part of the T2 Data Connection and you 
can use any or all of these functions to help you prepare your returns. 

T2 Data Connection – What’s Right for You? 
Using the features of the T2 Data Connection you can: 

• Transfer  data from the R&A workchart in one return to the R&A 
workchart in another return 

• Link data files so that the R&A workchart in one return is automatically 
updated with the information from actual data file of the associated 
corporation  

• Use the Allocation Scenarios on the allocation forms to help determine 
the optimal allocations based on the actual data in the linked returns. 

Depending on your situation and that of the corporate group, it may not be 
practical or even necessary to use all of these features for a given corporate 
group. 

In the following pages, we will present three different scenarios that you may 
encounter and suggest how you can use the T2 Data Connection to help prepare 
these returns.  

Scenario #1 – Associated Corporations 
You need to prepare the returns for three corporations that are associated 
CCPCs and all three have a December 31 year end.  

Corporation Name 
Taxable 
income 

Taxable capital 
for the year 

Prior Yr 
Taxable 
Capital Total assets Total Revenue 

Associated Corporation #1 $319,000 $647,000 $575,000 $826,000 $700,000 
Associated Corporation #2 $227,000 $3,176,000 $3,976,000 $3,291,000 $6,500,000 
Associated Corporation #3 $86,000 $1,362,000 $1,800,000 $1,707,000 $3,500,000 
            
  $632,000 $5,185,000 $6,351,000 $5,824,000 $10,700,000 

 



Suggested Approach: 
Step 1 – Prepare each return in the group 

Roll forward and prepare each of the tax returns in the group as far as possible 
aside from the information on related and associated corporations. 

Step 2 - Establish links to the various returns in the group 
Pick one of the returns to use as the initial return for purposes of identifying all 
of the returns in the group. 

Access the R&A Workchart (Jump Code: 9 WORKCHART). 

For each corporation already listed in the workchart, click  beside the field 
for the “Location and name of the linked file,” and then select the appropriate 
file for the current tax year. 

 

Taxprep will post a warning message when you attempt to link to a return 
that has a year end in different calendar year to help ensure that you do not 
accidentally select the wrong return.   

If you need to create a new copy of the R&A workchart, Taxprep will 
automatically prompt you to create the link to the appropriate data file. 

Importing Data 
When you link the return, the Create Link Wizard will then display the data 
that will be imported into the R&A workchart for that corporation. 

The “Current Value” field will display any existing data in the R&A workchart 
for the fields being imported. The “Imported Value” field displays the data that 
will be imported.  

You can choose not to import any of the data displayed by suppressing any of 
the data by removing the check mark.  

 



 
 

TIP  

You can view a list of data that was imported via the T2 Data Connection by 
using the “Imported Data” filter in Xpress.  

 

 

When you establish a link to another Corporate Taxprep data file, the link is 
unidirectional (i.e. one way). The link is used to access information contained 
in the source return (i.e. the data file that you selected when you 
established the link) while you are working in the current data file. 

 

Step 3 – Complete the R&A Workchart for each corporation 
When you link the returns, Taxprep will automatically import relevant 
information from these returns into the Related and Associated Corporations 
Workchart.  

If there are any corporations that were not in the prior year file, you will need 
to identify the relationship between those corporations and the filing 
corporation as well as provide any details for the percentage of shares owned 
by the filing corporation for Schedule 9 purposes. 



Step 4 - Determine the allocations between the returns in the group 
For each relevant form applicable to the corporate group (e.g. Schedules 23, 
49, CO-771.1.3, etc.), allocate the amounts for each corporation, if applicable.  

TIP  

You can easily view all of the forms that require allocations between 
corporations using the pre-defined form group “Corporate Group Allocation 
Scenarios” in the Form Manager. 

If you have established links to the other returns in the corporate group, then 
you can take advantage of the Allocation Scenario calculations on various 
allocation schedules to view the impact of a proposed allocation for the entire 
corporate group. 

To use an Allocation Scenario, enter a proposed allocation in the appropriate 

column (i.e. the column with the input fields) and then click . 

 
Taxprep will apply the proposed allocation to the data in each linked return 
and do a pro-forma calculation to determine the effect of that proposed 
allocation.  

TIP  

When you click , the Allocation Scenario on Schedule 23 will 
post an estimate of the maximum percentage of the SBD required. You can 
you can use this estimate to help guide you in your proposed allocations. 

If another user has one of the corporate group files open when you click 

, Taxprep will use the values in the last saved version of the file. 

The results of this calculation are posted to the allocation scenario portion of 
the applicable allocation form.  



 

The results of the Allocation Scenario calculation appear in the current 
return for information purposes only –the linked returns are not affected by 
this process at all. 

 

You can modify the proposed allocations and recalculate the results as many 
times as necessary until you have determined your optimal allocation. 

 

 
The following schedules include Allocation Scenarios: 

 
 

 

When you click , the allocation scenario results are updated in all 
of the various allocation schedules, not just the schedule that you are 
currently viewing.  

 



Step 5 – Save and close the return 
Save and close the initial return in which you entered the links and determined 
the allocations.  

Step 6 – Import the data into the remaining returns 
Open the next return in the group. 

Click Import Data/Corporate Group on the File menu. 

Select the return that you updated in Steps 1-5. 

Taxprep will display the list of the related and associated corporations in the 
group.  

 
If the current file already contains a list of related and associated corporations 
(e.g. rolled forward from the prior year), Taxprep will attempt to match up the 
remaining corporations using the BN, the name and the tax year.  

Even if the current file does not yet list any related or associated corporations, 
at a minimum, Taxprep will identify which corporation in the list is now the 
filing corporation, using the BN and the tax year. 



 

 

TIP  

Any links that you have established in the R&A Workchart will be imported 
along with the other data in the R&A workchart when the 
Import Data/Corporate Group command is used. 

Therefore, you can set up the links for all of the corporations in the group in 
one data file and then use the command Import Data/Corporate Group to 
copy all of these links to another data file. 

Step 7 – Save the return 
Step 8 - Repeat Step 6-7 for all remaining returns 

 

 

TRUC  

After importing data for each of the files in the group of related or associated 
corporations, click Recalculate on the Tools menu to refresh the diagnostics 
related to the T2 Data Connection. Note that the source files for each of the linked 
corporations are used to validate the values in the active file and to display these 
diagnostics. 



Scenario #2 – Related Corporations 
You are preparing the corporate returns for several members of a corporate 
group in which the corporations are related but not associated. In addition, the 
list of related corporations changes from year to year. You need to provide the 
list of related corporations in each return being filed. 

Suggested Approach: 
Step 1 – Update the list of related corporations in the R&A Workchart 

Pick one of the returns to use as the “master” return for purposes of updating 
the list of related corporations.  

TIP  

If you have a corporate group in which certain corporations are related to 
some corporations but not to others, then you may wish to pick the 
corporation with the largest number of related corporations as your initial 
return, to allow you to enter as much of the corporate group information as 
possible within the initial return. 

 

If you are also preparing the returns for the related corporations, you can 
update the information by linking to the relevant data file (e.g. if it is a new 
corporation and you want to import the name, BN and year end) as described in 
Scenario #1 – Step 1. 

Alternatively, you may choose to simply manually update the list of related 
corporations in the first return rather than acquiring the information by linking 
the returns.  

You will need to manually enter the information for any related corporations 
for which you are not preparing the tax return.  

 

TIP  

If you will not be linking to any returns, you may wish to disable the T2 Data 

Connection on the 1st copy of the 9 Workchart:  

When this option is disabled, Taxprep will no longer prompt for a link to a 
file when you create a new copy of the R&A Workchart.   

 

Step 2 – Save the return 
Step 3 – Import the updated R&A Workchart into the other returns 

1) Open the next related corporation return 

2) Click Import Data/Corporate Group on the File menu. 

3) Select the return that you updated in Step 1 as your source file. 



Taxprep will display the list of the related and associated corporations that 
were entered in the source return (as well as the source return).  

 

 
If the current file already contains a list of related and associated corporations, 
Taxprep will attempt to match up the remaining corporations using the BN, the 
name and the tax year.  

A corporation from the source file that is matched to a corporation found in 
the current file will be listed as an “Existing corporation” for the current filing 
corporation. Any other corporations will be displayed in the “New corporation” 
list.  

If Taxprep was unable to correctly match a corporation (e.g. because the BN 
was incorrect or not entered), click the down arrow to display the list of 
corporations in the current file and select the matching corporation. 

If applicable, click to remove the check mark beside any corporations that are 
not related to the current corporation. 

 

The command Import Data/Corporate Group does not delete any 
corporations from the R&A Workchart. Therefore, if you have rolled 
forward the file and have corporations listed that are no longer related, you 
will need to manually delete them from the R&A workchart. 

 

4) Once you have identified the corporations, click Next to continue.  



5) Click Next and then Finish to import the selected data. 

6)  If you have imported information for any corporations that were not 
previously listed in the R&A Workchart, then you will also need to enter: 
 

• the Relationship code for that corporation; and  

 
• the relevant information in the section for Schedule 9 (if applicable). 

 
This data reflects the relationship between the current filing 
corporation and that specific related corporation, so this information 
may vary from return to return depending on the corporate structure. 
As a result, this information is not imported when you use the Import 
Corporate Group command.  

 

If a corporation was listed in the R&A workchart last year, then the 
Relationship code and Schedule 9 information (where applicable) will be 
rolled forward automatically from the prior year and only needs to be 
reviewed for any changes in the corporate group ownership. 

Step 4 – Update the R&A Workchart for the remaining returns 
Repeat step 3 for each additional tax return in the group that you are 
preparing.  

Scenario #3 – Different Year Ends 
You are preparing the returns for a corporate group that consists of a large 
parent company and several smaller associated corporations. The taxable 
capital of the group exceeds $10 million and the corporation is subject to 
capital tax in several provinces. In addition, some of the corporations have 
different year ends. 

Suggested Approach: 
In this case, you may want to use different T2 Data Connection features 
depending on whether or not you are preparing the first return in the calendar 
year, the last return in the calendar year or one in between. 

Step 1 – Roll Forward the returns with the earliest year end 
The R&A workchart includes cells to track prior year information to better 
handle situations in which there are different year ends. This allows Taxprep to 
roll forward the relevant information from the prior year R&A workchart.  



TIP  

You must roll forward the files using Corporate Taxprep 2010 or a more 
recent version in order to have these new cells populated via the roll 
forward.  

Taxable Capital Employed in Canada 
For example, both the taxable capital in the current year, as well as the prior 
year taxable capital are now tracked. 

 
When you roll forward the filing corporation return, the current year taxable 
capital information on each copy of the R&A workchart will be rolled forward 
to the line Taxable capital employed in Canada in the last taxation year.  

Where the taxation year end of the related or associated corporation ends 
after the year end of the filing corporation, Taxprep will automatically use the 
prior year taxable capital amount (because the relevant amount is that of the 
last taxation year ending in the filing corporation’s tax year). 

Step 2 – Complete the returns for the first year end 
In addition to completing the return for the filing corporation, if any of the 
related and associated corporations have the same year end as the filing 
corporation, you may require some information from the current tax return 
(e.g. current year taxable capital).  

If this information has already been entered in the relevant data files, you can 
link to those data files as described in Scenario #1 – Step 2 so that this 
information is imported into the R&A Workchart. Otherwise, you can enter the 
relevant information manually. 

 

You should only link to the tax returns that have a year end in the same 
calendar year as the filing corporation to ensure that all allocations are 
consistent.  

 



Step 3 – Determine allocations 
While you will need to enter any applicable allocations in the first return filed 
in the calendar year, in this situation, the Allocation Scenarios may not be 
relevant because: 

• the allocations may be straightforward (e.g. 100% to the parent 
corporation), 

and/or  

• the information in the later returns may not be sufficiently complete to 
provide meaningful results. 

Step 4 – Save the Return  
Step 5 – Import the data into the remaining returns 

If there are other returns with the same year end as the filing corporation, you 
can complete the R&A Workchart in these returns using the command 
Import Data/Corporate Group on the File menu as described in Scenario #1. 

Step 6 – Roll Forward and prepare subsequent returns 
Later in the year, as they come up, roll forward and prepare the returns for the 
later year ends aside from the R&A Information. 

Step 7 – Import Allocations and other information from previously filed returns 
Use the Import Data/Corporate Data function to import the R&A information, 
including the links and the allocations from the returns already prepared. This 
will help you ensure that all returns have consistent information and that your 
subsequent returns utilize the allocation elections made for that calendar year.  

 

 

 

Subsequent Changes in Linked Returns 
If any data affecting the R&A Workchart is modified in any of the linked returns 
after the data has been transferred, you can update the data from all of those 
returns using the command Update Links to Corporations from the Tools 
menu. 

TRUC  

After importing data for each of the files in the group of related or associated 
corporations, click Recalculate on the Tools menu to refresh the diagnostics 
related to the T2 Data Connection. Note that the source files for each of the linked 
corporations are used to validate the values in the active file and to display these 
diagnostics. 



Taxprep will display any data items that differ between the source files and 
the current file that you are viewing. You can select to transfer any or all of 
the modified data. 

 

The allocations are not transferred when you use the Update Links to 
Corporations command with existing linked returns, to ensure that you do 
not accidentally overwrite your optimized allocations. 

 

Identifying Corporate Group Files 
You can use the field for the “Name of the Related/Associated Corporation 
Group” that appears on the first copy of the R&A workchart to help identify the 
files that form part of each corporate group. 

When you import the corporate group data from one return to another, the 
name of the corporate group will be imported as well.  

 

In order to ensure that all members of the corporate group can be easily 
identified, the corporate group name should be consistent across all of the 
corporations in the group. We therefore recommend that you do not change 
the original corporate group name that you imported from the initial return. 
If you do need to change the name, then you should ensure that it is changed 
in all of the files. 

 

The Corporate Group Name is an optional column in any of the Client Manager 
views (other than File Data). To add the Corporate Group Name to your view, 
click the column header and click Customize Columns. Then drag and drop the 
Corporate Group Name to the desired location in the view.  

By adding this column to your views, you can sort, filter or group based on the 
corporate group name.  

 

TIP  

To open all of the returns in a corporate group at the same time, filter on 
the corporate group name, press Ctrl+A (to Select All) then press Ctrl+O 
(to open the files). 

 

Tips for Managing your Corporate Group Files 
In order to minimize the amount of updating required to ensure that all of the 
data in the group is consistent, you may wish to consider the following tips: 



Try to complete all relevant R&A data before using the import 
While it may not be possible to complete all returns in a group at the same 
time (e.g. due to different year ends), if you can roll forward the files and 
enter the current year data that impacts on the R&A workchart for each 
corporation prior to linking the files, then you can minimize the number of 
times that you may need to subsequently update the data. 

If possible, determine allocations prior to import 
If you can determine your optimal allocations prior to using the 
Import Data/Corporate Group command, then you can save time as the 
allocations will be imported along with any corporate file links and the other 
data on the R&A workchart. 

Encourage all preparers to save their corporate group returns to a shared 
folder whenever possible.  

If they make changes to a return and only save it locally, you will be unable to 
access that data when updating the other returns in the group. 

Select a single file to be used to optimize the allocations. 
If the allocations are optimized in more than one file, you may spend time 
reconciling discrepancies between the files. If there are a number of preparers 
involved, you may even wish to use a customized status (e.g. “Allocations 
Optimized”) to identify which return contains the optimized allocations.  

 

T2 Data Connection – Frequently Asked Questions 
Import Data / Corporate Group vs. Linking Files 
Question: 

If there are only two corporations that are associated, do I still need to use the 
Import Data/Corporate Group command if I have linked the files? 

Answer: 
Not necessarily. You have two alternatives. 

In both cases, you would start in Corporation #1 and establish a link to 
Corporation #2 (which will import the relevant R&A information from 
Corporation #2 to Corporation #1).  

Then open the return for Corporation #2 and either: 

1) Use the Import Data/Corporate Group command to import the R&A 
workchart from Corporation #1 (which will also establish the link to 
Corporation #1).  
 
or 

2) In the R&A Workchart access copy #2 and click  then establish the 
link to Corporation #1 which will then import the relevant R&A data 
from Corporation #1.  



TIP  

If there are more than two corporations in the corporate group, you can save 
time by using the Import Data/Corporate Group command which can import all 
of the links at the same time. Otherwise you would need to create a link for 
each copy in the R&A Workchart. 

Import Data / Corporate Group vs. Update Links 
Question: 

What is the difference between using the command Import Data/Corporate 
Group on the File menu and Update Links to Corporations on the Tools menu? 

Answer: 
The Import Data/Corporate Group command imports all of the information 
from the R&A workchart in the source file; including any links established to 
returns in the group as well as any relevant allocations that are in the R&A 
workchart.  

The Update Links to Corporations command uses the links established to 
access each source file and check that the information in the current R&A 
workchart reflects the most recent version of the source return. Any 
differences will be displayed in the list of data to be imported (other than 
allocations, which are not affected by the update). If there was no link 
established, or the file cannot be found in the location indicated, then Taxprep 
will prompt you to create a link, unless the option to link to that specific 
corporation has been disabled (e.g. in the case of a related corporation for 
which you do not prepare the return).  

Accessing Files 
Question: 

I have established links between the returns in the corporate group. If I am in 
one of the returns in the group, is there a command that allows me to jump to 
one of the other returns in the group? 

Answer: 
Yes. Press Shift+F6 from one of the cells that is linked to the source file (e.g. 
an allocation cell).  

If there is a difference between the value for that cell in the current return 
and the source return, then you will be asked whether or not you wish to 
update the value. If you want to view the source file but not transfer an 
amount, press Shift+ F6 and answer No to the question shown below. The 
linked file will be opened, but no amount will be transferred. 

This command also appears on the shortcut (right-click) menu.  

TIP  

To return to the original file, use the Previous File on the View menu or 
press Ctrl+J. 



 

Rolling Forward Files 
Question: 

If I link the corporate group returns in the current year, are these links 
retained when I roll forward the file? 

Answer: 
No. The link is made to the tax return for a specific year end. Therefore, the 
link used last year would be to last year’s return. Once you roll forward your 
files, you will need to select the data file that represents the current year data 
file.  

TIP  

If you have a large number of corporations listed in the R&A workchart, you 
may find it faster to create your links using the command Update Links to 
Corporations on the Tools menu. This command will prompt you for a link for 
each corporation listed in the R&A workchart 

Moving Files 
Question: 

What happens if I established a link to an associated corporation return and 
then that return was subsequently moved to a different location?  

Answer: 
If you move a return, then when you open a data file that has a link to that 
return, or use the commands Import Data/Corporate Group, Update Links to 
Corporations or Calculate, you will be prompted to re-establish or remove any 
“broken” links. 

Question: 
If the link is broken, will I lose the data that was transferred into the R&A 
workchart? 

Answer: 
No. Any data that is already in the R&A workchart will not be affected when a 
link is “broken,” regardless of whether the data was entered manually or was 
imported. 

If you no longer require the link (i.e. because the current return has been 
completed), then you may wish to remove the check mark beside the check 
box Always keep the link and offer to restore it when in error for that 
return. That way you will not be prompted again to correct the link. 



Turning Off the Prompt to Link Files 
Question: 

I am entering information for a number of new related corporations, but I don’t 
prepare those returns so I will not be linking to them. Is there a way that I can 
stop Taxprep from prompting me to link to the file every time I click New? 

Answer: 
Yes. If you have a data file in which you will not be linking to other returns, 
you can override to remove the “X” beside “Enable T2 Data Connection” in the 
first copy in the R&A workchart, and Corporate Taxprep will no longer prompt 
for a link when creating any subsequent R&A workchart copies in that file. 

If you want to turn off the prompt to link returns for all of your data files, then 
disable the check box Enable T2 Data Connection in the “Options – Return” 
section of the Preparer Profile. 

However, in either case, if you find that you want to link a specific file, you 

can still click  beside the field “Location and name of the linked file” to add 
a link for a specific corporation. 

 

Even if the T2 Data Connection is disabled, you can still use the Import 
Data/Corporate Group command to import corporate group data from one 
return to another. 

 

Password Protection 
Question: 

Can I link to a password-protected file? 

Answer: 
Yes, but you will be prompted to provide the password when Taxprep tries to 
link to the file. You can avoid this request by entering the relevant passwords 
in your password list in the General pane of the Options and Settings dialog 
box.  
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